Ubuntu: VMware and mount.ntfs high cpu usage fix 6

If we run VMWare player on Ubuntu to run guest OS, and if the virtual machine files are stored in a NTFS partition (like a large External HDD), then chances are that you would notice mount.ntfs taking up almost 100% cpu usage once the Vmware’s Image is started. This will most certainly leave your system unusable until you are able to get the vmware down.

The old remedy of changing the .vmx file and adding mainMem.useNamedFile = "FALSE" does not work any more. As per this post, the solution is to provide a non-ntfs location for storing the vmware suspend and snapshot files as a working directory. The same can be edited in the vmplayer’s option screen as shown below or added as a line in the .vmx file as workingDir = “../../../opt/vmware”

Ensure the directory provided has write permissions for the user configured to run the vm.

Please like & share:

6 thoughts on “Ubuntu: VMware and mount.ntfs high cpu usage fix

  1. Reply Segrey Dec 11,2013 8:36 pm

    It’s very useful. Big, Big thanks to you human.

  2. Reply Nics Oct 1,2014 2:48 pm

    Thank you!

  3. Reply ToS Jan 24,2015 3:11 am

    Hi,

    thanks for pointing this out. Havig a large.vmx on an external USB3 HDD which runs on NTFS. On my Ubuntu 14.10 mount.ntfs stalls my system.

    Now changing the working directory into my “homefolder/vmwareTMP” which runs on a SSD is just ridiculously smooth. There is essentially no hint that it is running in a virtual system anymore.

    Absolute brilliant!

    THX a lot!

  4. Reply Alf Feb 12,2015 6:30 pm

    thanks a lot!

Leave a Reply to Alf Cancel Reply

  

  

  


*